


Class-4
Chapter-1  Computer Devices and Types 

Exercise:
A. 1.  (b)  2. (c)  3.  (b)  4.  (c)  
B. 1.  Keyboard 2.  Mouse 3. Monitor 4.  Joysck 
C. 1. Analog Computer: 
  These computers are used to process analog data. Analog data 

is of connous nature and which is not discrete or separate.  
 2. Hybrid Computer: 
  It is combinaon of an analog and a digital computer. It is a 

digital computer that accepts analog signals, converts them to 
digital form. 

 3. Digital Computer: 
  It works with digits to represent numerals, le�ers or other 

special symbols. 
D. 1.  YES  2.  YES 3.  NO 4. YES  
 5.  YES
E. 1. A computer is a machine or device that performs processing, 

calculaons and operaons based on instrucons provided by 
a so�ware or hardware program.  

 2.
 
       
 
   
 
 3.  The CPU is the main processing device in the computer. 
   Input   Process   Output
       
        
   
 

 4.  Categories of computers according to the purpose: 
  1. Analog   2. Hybrid  3. Digital

Input Devices Output Devices 

a) They are used to input 
informaon into the 
computer.

b) Keyboard 

a) They are used to get the 
output of the result on 
the display device.

b) Monitor  

Input is given in 
the form of data 
or instrucons.

Processing is 
done on the 
data based on 
the given 
instrucon.

The generated 
result is 
displayed here.
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 1.  Analog Computer: 
  These computers are used to process analog data. Analog data 

is of connous nature and which is not discrete or separate.  
 2.  Hybrid Computer: 
  It is combinaon of an analog and a digital computer. It is a 

digital computer that accepts analog signals, converts them to 
digital form. 

 3.  Digital Computer: 
  It works with digits to represent numerals, le�ers or other 

special symbols. 
 4.  Minicomputers: 
  T h e s e  c o m p u te rs  a re  s o m e w h e re  i n  b e t w e e n  a 

microcomputer and a mainframe. They are stand alone device 
that was ideal for use by small and mid sized businesses. Eg- 
PDP-8 

 Microcomputer:
 These computers have microprocessor as it’s CPO. They are 

physically small as compared to mainframe and minicomputers 
and are known as personal computers. 

 Eg- IBM PC. 

Acvity Time: 
A. Do it yourself. 
B. Do it yourself.
C. Do it yourself. 

Chapter-2  Computer �o��are

Exercise:
A. 1.  (b)   2.    (a)  3.  (b)   4.  (b)  
B. 1.  Operang System 2.    MS DOS 3.  Operang System  
 4.  Word Processors  
C. 1.  Operang System So�ware: 
  It acts as an interface between the computer and the user. 

Eg-Windows.
 2.  Applicaon So�ware:
  It is a so�ware created for a specific purpose. Eg- MS Word. 
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 3.  Microso� Windows:
  Microso� created the Windows O/S in the mid 1980s. 

Windows 10 is the latest version of Windows O/S.
 4.  Linux:
  It is one of the popular version of UNIX O/S. It is open-source as 

its source code is freely available. 
D. 1.  YES  2.  YES  3.  NO   4. YES 
 5.  YES  6.  YES
E. 1.  Candy Crush  2.  Mario  3.  Angry birds  
 4.  Teen Pa�
F. 1.  A set of instrucons stored digitally within the computer’s 

memory is known as so�ware.
 2.  It controls the basic funcons of a computer.
 3.  Window 8 - 2012 
  Windows 7- 2009
  Windows Vista- 2007
  Windows XP- 2001 
 4.  It means any s/w that can be installed on a single computer 

(laptop or a desktop) and used to perform specific tasks.
 5.  Microso� Window’s latest version is Windows 10. Microso� 

created the Windows O/S in the mid 1980s. 
 
Acvity Time:  
A. Do it yourself.
B. Do it yourself.
C. Do it yourself.

 Chapter-3 Windows 10
Exercise:
A. 1.  (c)  2.  (a)  3.  (b) 4.  (b) 
 5.  (a)
B. 1.  Start Menu: 
  It is the most important feature of windows 10. It is used to 

access your applicaons. 
 2.  Task View:
  It is a system that provides an experience to work more 

efficiently with mulple applicaons. We can quickly jump 
between open applicaons and spread projects on to separate 
desktops to stay on parcular task. 
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 3.  Connuum:
  It is a way for windows to detect the hardware you are using. It 

ensure that we always have the opmum interface on our 
machine. 

 4.  Cortana:
  It is a virtual assistant created by Microso� for Windows 10. It 

can gets you the installed apps, documents, search results 
from the web. 

C. 1.  NO  2.  YES  3.  YES  4.  YES  
 5.  NO  
    
D. 

E.  Two features of managing mulple windows in Windows 10: 
 a)  Flip  :  We can use Flip to switch between open 

windows.
 b)  Snap :  It is used to arrange all our open windows 

using the mouse, keyboard or the Snap 
Assist feature. 

Acvity Time: 
A. Do it yourself.
B. Do it yourself. 
C. 1. WIN+CTRL+Le��Right
 2. WIN+CTRL+D
 3. WIN + CTRL+ F4
 4. WIN+ TAB  

Chapter-4 MS Word 2016
Exercise: 

A. 1.  (a) 2. (a) 3.  (c)  4.  (b) 5.  (a)
B. 1.  YES  2.  YES 3.  YES 4.  YES  
 5.  NO

Connuum Control Panel 

It is a way for windows to 
detect the hardware you 
are using and ensure that 
you always have the 
opmum interface on your 
machine.

It  lets  you change the 
se�ngs, styles, font size, 
font style etc.  of  your 
system.   
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C. 1.  Selecng any part of the text. 
 2.  Selecng a paragraph. 
 3.  Selecng a sentence. 
D. 1.  Word 2016 is the upgraded version of the Microso� Word. 
 2.  a)  Navigate a Backstage view, then click open. 
  b)  Select This PC, then click Browse.
  c)  Locate and select your document, then click open.
   The selected document will appear on the Word 2016 

window. 
 3.  Using the Inseron Point to Add text.
  i) Blank document
  ii)  Adding spaces
  iii) New paragraph line
  iv)  Manual placement 
  v)  Arrow keys   
 4.  We can use the arrow keys on our keyboard to move the 

inseron point. The le� and right arrow keys will move 
between adjacent characters on the same line, while the up 
and down arrows will move between paragraph lines. 

 5.  a)  Select the text on which you wish to apply WordArt effect. 
  b)  Click on the Insert tab"Select WordArt opon.
  c)  Choose the desired effect from the WordArt gallery.
  d)  A placeholder appears with the highlighted text.
  e)  Now, enter the text. 
Acvity Time:
A. Do it yourself.
B. Do it yourself.
C. Do it yourself. 

Chapter-5 Formang in MS Word 2016
Exercise: 

A. 1.  (c)  2.  (c) 3.  (a) 4.  (a) 

B. 1.  Print Preview 2.  inches  

 3.  Add space Before/A�er paragraph 

 4.  Clipboard 5.  15 

C. 1.  NO  2.  YES  3.  YES 4.  YES  

 5.  NO
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D.  1.  It is a wonderful tool in Word. With the help of this tool, we can 
apply the already exisng forma�ng  of a text to some other 
text.

 2.  a)  Click the File tab.
  b)  Select the Print opon. 
   Print screen open.
  c)  Click on Print bu�on. 
 3.  a)  Font type    b)  Font size  
  c)  Font color    d)  Bold 
  e)  Italic    f)  Underline etc. 
 4.  a)  Font type    b)  Font size   
  c)  Bold    d)  Italic  
  e)  Underline etc.
 5. a)  Le� alignment- It align the text to the le� margin of the page.
  b)  Center- Aligns the text to the center of the page.
  c)  Right- Aligns the text to the right margin of the page. 
  d)  Jusfy- It aligns the text to both the le� and right margin 

of the page.
Acvity Time:
Do it yourself. 

Chapter-6 MS PowerPoint 2016 
Exercise:
A. 1.  (c)  2.  (a)  3. (a)   4. (a) 

B. 

C. 1.  Slide Pane: 
  It displays the current view of the slide in which you work.
 2.  Notes Pane: 
  It displays the notes for the current slide.

Save Save As

When you create or edit a 
presentaon, you will use 
the Save command to save 
your changes.

You will use this command to 
create a copy of a 
presentaon while keeping 
the original.   
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 3.  Status Bar:

  It displays the number of slides, words and an error if your 
document contains. 

 4.  Title Bar: 

  This bar allows you to view the current document name.

 5.  Quick Access Toolbar:

  It displays the quick commands like Save, Undo, Redo etc. 

 6.  Ribbon: 

  The ribbon is divided into tabs, these tabs are also called 
menus. 

D. 1.  Locate and select the Save command on the Quick Access 
Toolbar. 

 2.  If you’re saving the file for the first me, the Save As pane will 
appear in backstage view. 

 3.  You will then need to choose where to save the file and give it a 
file name.

 4.  Click Browse to select a locaon on your computer. 

  The Save As dialog box will appear.

 5.  Select the locaon where you want to save the presentaon.

 6. Enter a file name for the presentaon, then click Save. 

  The presentaon will be saved. 

E. Steps to create a new presentaon:

 a)  Select the File tab to go to Backstage View. 

 b) Select New and then click Blank Presentaon. A new 
presentaon will appear. 

Acvity Time:
A. Do it yourself.

B.
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Slide Sorter View Slide-Show View

It displays a miniature view 
of all the slides of a 
presentaon in horizontally 
sequenced thumbnails.   

This view is used when you 
deliver your presentaon to 
audience.    
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Chapter-7 Scratch 
Exercise:

A. 1.  (b)  2.  (a) 3.  (c)  4.  (c)

B. 1.  (d)  2.  (a) 3.  (b)  4.  (c)

C. 1.  SCRATCH 2. SPRITE 3.  MOTION  4.  STAGE 

D. a)  It can be used by people of all ages. 

 b)  It allows young people to integrate creavity in storytelling, 
games and animaon.

 c)  It allows students to develop 21�� century skills.

 d)  Students and teachers can create and share resources. 

E. 1.  Scratch is a programming language that makes it easy to create 
interacve stories, animaons etc.

 2.  Steps to create New Project: 

  a)  Click on the File menu.

  b)  Choose the New opon. 

  c)  Select the Moon Block. 

 3.  Save the Project: 

  a)  Click the File menu.

  b)  Choose the Save opon.

   The Save Project dialog box appears.

  c)  Select the folder.

  d)  Type the name in the File name box.

  e)  Click Save bu�on.

 4.  Exit from the Project: 

  a)  Click on the File menu.

  b)  Click on the Quit opon.

Acvity Time: 

A. Do it yourself.

B. w Agree

 w Agree

 w Agree

 w Agree
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Chapter-8 Simple Movement of Sprite  
Exercise:

A. 1.  (a)  2.  (a) 3.  (b)  4.  (a) 

B. 1.  cat   2.   3.  top 4.   

 5.   

C. 1.  NO  2.  YES 3.  YES 4.  NO  

 5.  YES 

D. 1.  a) show  b)  hide

 2. 

 3.  It is used to run a script.

 4.  New Costume opon.

 5.    block makes the sprite wait for some seconds. This 
block is present in Control block category.

Acvity Time:
A. Do it yourself.
B. 1.  It will make the sprite to move 10 steps.
 2.  This block changes the colour and other graphical effects 

applied to the sprite by the specified number. 
 3.  It will make the sprite changing its costume. 
 4.  It will make the sprite                      before moving to the next 

block of the script. 
 5.  It will repeat the acons of the sprite 15 mes.

 6.  It will turn the sprite to 15 degree.   

Chapter-9 Internet
Exercise:

A. 1.  (a)  2.  (b) 3.  (b) 4.  (a)

B. 1.  search engine  2.  network  3.  bookmark  

 4. !  5.  MODEM

C. 1.  (d)  2.  (c)  3.  (a)  4.  (b) 

D.  1.  YES  2.  NO 3.  YES 4.  YES  

 5.  NO 
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E. 1.  It allows your system to connect with other computers to send 
data over telephone or cable lines. 

 2.  Uses of Internet: 

  a)  It is used to send Email.

  b)  It is helpful in communicaon. 

 3.  Web Browser is a computer so�ware that helps us to access 
informaon on the internet. Eg- Google Chrome. 

 4.  Modem, Computer System, Telephone Line, Internet 
Connecon and Web Browser. 

 5.  MODEM stands for Modulator-Demodulator.

Acvity Time:

A. 1. Internet Service Provider

 2. Electronic-Mail

 3. Modulator-Demodulator

 4. World Wide Web

 5. Advanced Research Project Agency Network 

 6. Uniform Resource Locator 
B. Do it yourself. 

Project-1
Do it yourself.

Project-2
Do it yourself.

NCO
Do it yourself. 
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